Added ability to define multiple functions (without parameters) and
[zilutils.git] / zilasm / configure.ac
index 881332dc812382b7b14f15ed0145d551b509ca5c..8e7bb47728e2f881a80931eac2a4e4d171a598b9 100644 (file)
@@ -2,6 +2,7 @@
 # Process this file with autoconf to produce a configure script.
 #
 # Copyright (C) 2015 Alexander Andrejevic <theflash AT sdf DOT lonestar DOT org>
+# Copyright (C) 2019 Jason Self <j@jxself.org>
 #
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU Affero General Public License as
@@ -20,7 +21,7 @@
 
 AC_PREREQ([2.65])
 AC_INIT([zilasm], [0.1])
-AC_CONFIG_SRCDIR([main.c])
+AC_CONFIG_SRCDIR([main.cpp])
 AC_CONFIG_HEADERS([config.h])
 
 AM_INIT_AUTOMAKE([-Wall -Werror foreign])
@@ -28,6 +29,7 @@ AC_CONFIG_FILES([Makefile])
 
 # Checks for programs.
 AC_PROG_CC
+AC_PROG_CXX
 
 # Checks for libraries.