Added ability to define multiple functions (without parameters) and
[zilutils.git] / zilasm / configure.ac
index 7c07031282e1c5dbf1e1110a46657a087009e2d3..8e7bb47728e2f881a80931eac2a4e4d171a598b9 100644 (file)
@@ -2,6 +2,7 @@
 # Process this file with autoconf to produce a configure script.
 #
 # Copyright (C) 2015 Alexander Andrejevic <theflash AT sdf DOT lonestar DOT org>
+# Copyright (C) 2019 Jason Self <j@jxself.org>
 #
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU Affero General Public License as
 # You should have received a copy of the GNU Affero General Public License
 # along with this program.  If not, see <http://www.gnu.org/licenses/>
 #
+# SPDX-License-Identifier: AGPL-3.0-or-later
 
 AC_PREREQ([2.65])
 AC_INIT([zilasm], [0.1])
-AC_CONFIG_SRCDIR([main.c])
+AC_CONFIG_SRCDIR([main.cpp])
 AC_CONFIG_HEADERS([config.h])
 
-AM_INIT_AUTOMAKE
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
 AC_CONFIG_FILES([Makefile])
 
 # Checks for programs.
 AC_PROG_CC
+AC_PROG_CXX
 
 # Checks for libraries.