Updating to reflect the latest work
[zilutils.git] / zilasm / Makefile.am
index 9378980dcf0a0e5f0f16bcf873d56cbf96625ba9..5faa8ef82e4009ab963356bb14d3b4a7a63270d7 100644 (file)
@@ -2,6 +2,7 @@
 # Process this file with automake to produce Makefile.in.
 #
 # Copyright (C) 2015 Alexander Andrejevic <theflash AT sdf DOT lonestar DOT org>
+# Copyright (C) 2019 Jason Self <j@jxself.org>
 #
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU Affero General Public License as
@@ -19,6 +20,6 @@
 # SPDX-License-Identifier: AGPL-3.0-or-later
 
 bin_PROGRAMS = zilasm
-
-zilasm_SOURCES = main.c opcodes.c symtable.c header.c parser.c directives.c labels.c zmem.c
-include_HEADERS =       opcodes.h symtable.h header.h parser.h directives.h labels.h zmem.h
+man_MANS = zilasm.1
+zilasm_SOURCES = main.cpp opcodes.c symtable.c header.cpp parser.cpp directives.c labels.cpp string_table.cpp zmem.c
+include_HEADERS =       opcodes.h symtable.h header.h parser.h directives.h labels.h string_table.h zmem.h