Added ability to define multiple functions (without parameters) and
[zilutils.git] / zilasm / Makefile.am
index 5134797e6ee041a9cf829e007c29199a42dd605b..78f5d37f19979a361b55ececf37de1cd8a2c33fa 100644 (file)
@@ -2,6 +2,7 @@
 # Process this file with automake to produce Makefile.in.
 #
 # Copyright (C) 2015 Alexander Andrejevic <theflash AT sdf DOT lonestar DOT org>
 # Process this file with automake to produce Makefile.in.
 #
 # Copyright (C) 2015 Alexander Andrejevic <theflash AT sdf DOT lonestar DOT org>
+# Copyright (C) 2019, 2020 Jason Self <j@jxself.org>
 #
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU Affero General Public License as
 #
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU Affero General Public License as
@@ -20,5 +21,5 @@
 
 bin_PROGRAMS = zilasm
 man_MANS = zilasm.1
 
 bin_PROGRAMS = zilasm
 man_MANS = zilasm.1
-zilasm_SOURCES = main.c opcodes.c symtable.c header.c parser.c directives.c labels.c zmem.c
-include_HEADERS =       opcodes.h symtable.h header.h parser.h directives.h labels.h zmem.h
+zilasm_SOURCES = main.cpp compiler.cpp opcodes.c symtable.c header.cpp parser.cpp directives.cpp labels.cpp string_table.cpp zmem.c
+include_HEADERS =       opcodes.h symtable.h header.h parser.h directives.h labels.h string_table.h zmem.h