fwcutter: Update copyright information
[b43-tools.git] / fwcutter / debian / rules
1 #!/usr/bin/make -f
2
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
5
6 INSTALL := install -o root -g root -m 755
7
8 CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
9 CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
10
11 version=$(shell dpkg-parsechangelog | grep urgency | awk '{ print $$2; }'| \
12 sed -e s/"("// -e s/")"// | cut -d"-" -f1)
13
14 %:
15         dh $@
16
17 override_dh_auto_build:
18         dh_auto_build -- CFLAGS="$(CFLAGS) $(CPPFLAGS) -std=c99 -fomit-frame-pointer -pedantic -D_BSD_SOURCE \
19         -DFWCUTTER_VERSION_=`echo $(version) | cut -d: -f2`"
20
21 override_dh_auto_clean:
22         rm -f b43-fwcutter
23         rm -rf $(CURDIR)/debian/b43-fwcutter/usr/man    
24
25 override_dh_installchangelogs:
26         dh_installchangelogs $(CURDIR)/debian/b43-fwcutter.upstream-changelog
27
28 override_dh_auto_install:
29         $(INSTALL) b43-fwcutter $(CURDIR)/debian/b43-fwcutter/usr/bin