Implement a Makefile for Inform.
[inform.git] / src / Makefile.am
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644 (file)
index 0000000..975223d
--- /dev/null
@@ -0,0 +1,17 @@
+# This file is part of Inform.
+#
+# Inform is free software: you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# theFree Software Foundation, either version 3 of the License, or
+#(at your option) any later version.
+#
+# Inform is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Inform. If not, see https://gnu.org/licenses/
+
+bin_PROGRAMS = inform
+inform_SOURCES = arrays.c asm.c bpatch.c chars.c directs.c errors.c expressc.c expressp.c files.c header.h inform.c lexer.c linker.c memory.c objects.c states.c symbols.c syntax.c tables.c text.c veneer.c verbs.c
\ No newline at end of file