Silence some compile warnings.
[super-star-trek.git] / src / Makefile.am
index 2249438d518054d2828ba4e55da31d6bdfd8dec1..837cd067bb53acad8a0ec92548c336353f95f6f3 100644 (file)
@@ -1,5 +1,8 @@
-AM_CFLAGS = -Wall -Wimplicit -Wunused -Wmissing-prototypes \
-    -Wuninitialized -fno-inline -O1 -DDATA_DIR=\"$(pkgdatadir)\" @CFLAGS@
+AM_CFLAGS = -Wall -Wimplicit -Wunused -Wmissing-prototypes -Wundef \
+    -Wuninitialized -Wdeclaration-after-statement \
+    -fno-inline -O1 -DDATA_DIR=\"$(pkgdatadir)\" \
+    -DLOCALEDIR=\"$(datadir)/locale\" \
+    @CFLAGS@
 
 bin_PROGRAMS = sst
 
@@ -19,3 +22,7 @@ sst_SOURCES = \
 EXTRA_DIST = \
        sst.h \
        sstlinux.h
+
+# Experimental XaW code, not yet integrated with the game
+xio: xio.o
+       gcc xio.c -lXaw3d -o xio