All old versions moved to 'historic' directoery.
[super-star-trek.git] / historic / c-version / src / Makefile.am
diff --git a/historic/c-version/src/Makefile.am b/historic/c-version/src/Makefile.am
new file mode 100644 (file)
index 0000000..837cd06
--- /dev/null
@@ -0,0 +1,28 @@
+AM_CFLAGS = -Wall -Wimplicit -Wunused -Wmissing-prototypes -Wundef \
+    -Wuninitialized -Wdeclaration-after-statement \
+    -fno-inline -O1 -DDATA_DIR=\"$(pkgdatadir)\" \
+    -DLOCALEDIR=\"$(datadir)/locale\" \
+    @CFLAGS@
+
+bin_PROGRAMS = sst
+
+sst_SOURCES = \
+       ai.c \
+       battle.c \
+       events.c \
+       finish.c \
+       moving.c \
+       planets.c \
+       reports.c \
+       setup.c \
+       sst.c \
+       io.c \
+       sstlinux.c
+
+EXTRA_DIST = \
+       sst.h \
+       sstlinux.h
+
+# Experimental XaW code, not yet integrated with the game
+xio: xio.o
+       gcc xio.c -lXaw3d -o xio