add -Wunused-but-set-variable
[open-ath9k-htc-firmware.git] / target_firmware / CMakeLists.txt
index db31dc471eef82763e13f312999e501fb5bff6c9..e167b36850db3b40192c367530dc6def895bec26 100644 (file)
@@ -40,7 +40,17 @@ CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
 PROJECT(ath9k_firmware NONE)
 ENABLE_LANGUAGE(C)
 
-ADD_DEFINITIONS(-g -Os -Wunused-label -Wunused-variable -Wunused-value -Wpointer-arith -Wundef -nostdlib -Wundef)
+ADD_DEFINITIONS(
+       -g -Os
+       -Wunused-label
+       -Wunused-variable
+       -Wunused-value
+       -Wpointer-arith
+       -Wundef
+       -nostdlib
+       -Wundef
+       -Wunused-but-set-variable
+)
 ADD_DEFINITIONS(
        -D_RAM_
        -DBIG_ENDIAN -D_BYTE_ORDER=_BIG_ENDIAN