fix missing licenses
[open-ath9k-htc-firmware.git] / target_firmware / CMakeLists.txt
index 12ffc8b66591e5c0fda0c4ec216bc88870021c0f..db31dc471eef82763e13f312999e501fb5bff6c9 100644 (file)
@@ -1,3 +1,39 @@
+##
+ # Copyright (c) 2013 Qualcomm Atheros, Inc.
+ #
+ # All rights reserved.
+ #
+ # Redistribution and use in source and binary forms, with or without
+ # modification, are permitted (subject to the limitations in the
+ # disclaimer below) provided that the following conditions are met:
+ #
+ #  * Redistributions of source code must retain the above copyright
+ #    notice, this list of conditions and the following disclaimer.
+ #
+ #  * Redistributions in binary form must reproduce the above copyright
+ #    notice, this list of conditions and the following disclaimer in the
+ #    documentation and/or other materials provided with the
+ #    distribution.
+ #
+ #  * Neither the name of Qualcomm Atheros nor the names of its
+ #    contributors may be used to endorse or promote products derived
+ #    from this software without specific prior written permission.
+ #
+ # NO EXPRESS OR IMPLIED LICENSES TO ANY PARTY'S PATENT RIGHTS ARE
+ # GRANTED BY THIS LICENSE.  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT
+ # HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED
+ # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+ # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+ # DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
+ # LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+ # CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+ # SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
+ # BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+ # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE
+ # OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
+ # IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ ##
+
 SET(CMAKE_C_COMPILER_WORKS 1)
 
 CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
@@ -77,6 +113,8 @@ ELSE()
 ENDIF()
 
 INCLUDE_DIRECTORIES(
+       ${CMAKE_SOURCE_DIR}/include
+       ${CMAKE_SOURCE_DIR}/magpie_fw_dev/target/
        ${CMAKE_SOURCE_DIR}/magpie_fw_dev/target/inc
        ${CMAKE_SOURCE_DIR}/magpie_fw_dev/target/inc/xtensa-elf
        ${CMAKE_SOURCE_DIR}/magpie_fw_dev/target/inc/${PLATFORM_NAME}
@@ -99,6 +137,7 @@ ADD_CUSTOM_COMMAND(
        DEPENDS firmware
        COMMAND ${CMAKE_C_COMPILER}
                -nostdlib
+               -fno-lto
                -Wl,--start-group
                ${CMAKE_BINARY_DIR}/libfirmware.a
                -Wl,--end-group
@@ -110,6 +149,8 @@ ADD_CUSTOM_COMMAND(
        OUTPUT fw.bin
        DEPENDS fw.elf
        COMMAND ${CMAKE_OBJCOPY}
+               --change-section-lma .boot-0x400000
+               --change-section-vma .boot-0x400000
                --change-section-lma .text-0x400000
                --change-section-vma .text-0x400000
                -O binary fw.elf fw.bin