carl9170 firmware: extract tx and rx code from wlan.c into separate files
[carl9170fw.git] / carlfw / CMakeLists.txt
index 2a87dc0b99c3a0feada90e99ff4d58f80636ed13..fe6857263a68d30f6a6ad10fb0d781e534a4c33f 100644 (file)
@@ -16,7 +16,8 @@ set(CARLFW_CFLAGS "${CARLFW_CFLAGS_DEF} ${CARLFW_CFLAGS_EXTRA} ${CARLFW_CFLAGS_A
 
 include_directories (../include/linux ../include/shared ../include include)
 
-set(carl9170_main_src src/main.c src/wlan.c src/fw.c src/gpio.c src/timer.c
+set(carl9170_main_src src/main.c src/wlan.c src/wlanrx.c src/wlantx.c
+                     src/fw.c src/gpio.c src/timer.c
                      src/uart.c src/dma.c src/hostif.c src/reboot.S
                      src/printf.c src/rf.c src/cam.c src/wol.c)