carl9170 firmware: abort build if stack frame > 128
[carl9170fw.git] / carlfw / CMakeLists.txt
index b7057177e28e50222cf0527c0d25a74268979135..95a4cc41427f96e4324006d966870889efe0e731 100644 (file)
@@ -6,7 +6,7 @@ include("../extra/sh-elf-linux.cmake")
 include("../config.cmake")
 
 set(CARLFW_CFLAGS_WARNING "-W -Wall -Wextra -Wunreachable-code -Winline -Wlogical-op -Wno-packed-bitfield-compat -Winit-self -Wshadow -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wformat=2 -Wcast-align -Wmissing-format-attribute -Wmissing-prototypes -Wtype-limits -Wmissing-declarations -Wmissing-noreturn -Wredundant-decls -Wnested-externs -Wdisabled-optimization -Wpointer-arith -Wvolatile-register-var -Waddress -Wbad-function-cast -Wunsafe-loop-optimizations")
-set(CARLFW_CFLAGS_EXTRA "-mbitops -std=gnu99 -ffunction-sections")
+set(CARLFW_CFLAGS_EXTRA "-mbitops -std=gnu99 -ffunction-sections -Wframe-larger-than=128 -Werror")
 
 if (CONFIG_CARL9170FW_AGGRESSIVE_CFLAGS)
        set(CARLFW_CFLAGS_AGGRESSIVE "-fomit-frame-pointer -fsee -frename-registers -ftree-vectorize")