carl9170 firmware build: explicitly list carl9170.elf in dependency
[carl9170fw.git] / carlfw / CMakeLists.txt
index 8647a759d3e17a89d5883420a75c1c3b4ace1c30..c32b43fdd13d569cf4a66f765b38de3305838c97 100644 (file)
@@ -39,7 +39,7 @@ set_target_properties(carl9170.elf PROPERTIES LINKER_LANGUAGE C)
 set_target_properties(carl9170.elf PROPERTIES COMPILE_FLAGS "${CARLFW_CFLAGS}")
 set_target_properties(carl9170.elf PROPERTIES LINK_FLAGS "${CARLFW_CFLAGS} -Wl,-Tcarl9170.lds")
 
-add_custom_target(firmware ALL)
+add_custom_target(firmware ALL DEPENDS carl9170.elf)
 
 add_custom_command(
        DEPENDS carl9170.elf