Added code auditing with cppcheck.
[wumpus.git] / wumpus.spec
1 Summary: faithful transcription of the 1974 Atari Wumpus game
2 Name: wumpus
3 Version: 1.4
4 Release: 1
5 License: BSD
6 Group: Games
7 URL: http://www.catb.org/~esr/wumpus/
8 Source0: %{name}-%{version}.tar.gz
9 BuildRoot: %{_tmppath}/%{name}-root
10 #Destinations: freshmeat
11
12 %description
13 WUMPUS is a bit of retrocomputing nostalgia.  It is an *exact* clone, even
14 down to the godawful user interface, of an ancient classic game.  This version
15 fixes two minor bugs in my original 1992 USENET posting of the source.  
16 Superhack is a structurally similar game with a different premise.
17
18 %prep
19 %setup -q
20
21 %build
22 make
23 make wumpus.6
24
25 %install
26 [ "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
27 mkdir -p "$RPM_BUILD_ROOT"/usr/bin
28 mkdir -p "$RPM_BUILD_ROOT"/usr/share/man/man6/
29 cp wumpus superhack "$RPM_BUILD_ROOT"/usr/bin
30 cp wumpus.6 "$RPM_BUILD_ROOT"/usr/share/man/man6/
31
32 %clean
33 [ "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
34
35 %files
36 %defattr(-,root,root,-)
37 %doc README
38 %{_bindir}/wumpus
39 %{_bindir}/superhack
40 %{_mandir}/man6/wumpus.6*
41
42 %changelog
43 * Thu Jun 05 2014 Eric S. Raymond <esr@snark.thyrsus.com> 1.5
44 - Fixed a minor bug in the superhack startlet check.
45
46 * Thu Oct 21 2010 Eric S. Raymond <esr@snark.thyrsus.com> 1.4
47 - Ported to modern C.
48 - License changed to BSD.
49
50 * Sun Dec 28 2003 Sean Reifschneider <jafo-rpms@tummy.com> 1.3
51 - Changing the .spec file so that it installs under a build-root.
52 - Changes so that the RPM can be built as a non-root user.
53
54 * Sun Dec 28 2003 Eric S. Raymond <esr@snark.thyrsus.com> 
55 - Initial build.
56
57