Update README
[loomr.git] / README.md
1 # loomR
2
3 ### An R interface for loom files
4
5 For more information on loom files, please see the documentation for [loompy](https://github.com/linnarsson-lab/loompy)
6
7 ## Dependencies
8
9 loomR depends on:
10  - [R](https://cran.r-project.org/) v3.4.x
11  - The [hdf5r](https://github.com/hhoeflin/hdf5r) package
12  - The HDF5 [C++ API](https://support.hdfgroup.org/HDF5/release/obtainsrc.html)
13
14 To get the HDF5 C++ API, please see the table below:
15
16 | Operating system | Command |
17 | ---------------- | ------- |
18 | macOS | Using [Homebrew](https://brew.sh/), `brew install hdf5` |
19 | Debian and Debian-based OSes | `sudo apt install libhdf5-dev` |
20 | Red Hat-based OSes | `sudo dnf install hdf5-devel` or `sudo yum install hdf5-devel` |
21 | Windows | Download precombiled binaries [here](https://github.com/mannau/h5-libwin) |